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Basic Tutorials SAAM 11 v.2.2 Working with Tables

Working with Tables

Prerequisites

The prerequisite for this tutorial is having worked through the SAAM |1 introductory
tutorial, “Getting Started with SAAM Il Compartmental.”

What you will learn in this tutorial

The purpose of this tutorial is to show you how to use Tables to export information from SAAM
Il to other applications. You will learn

e How to export information to a .CSV file (Part 1)
e How to change the number of solution points in your file to export (Part 2)
e How to export statistical information to a .CSV file.

Files Required
Study Files: The study file for this tutorial is
study_0.stu

This file is included as part of this tutorial. This file is the same as study_0.stu that is
installed in the SAAM Il program folder.

Introduction

This tutorial focuses on how to use tables that can be created by SAAM 11 for export to .CSV
files. Many users want to post-process results from SAAM II. This can include using other
graphics packages or statistical packages.

It should be pointed out that, while this tutorial will focus on tables created by SAAM Il in the
Tables window, SAAM I generates other tables of output that can be exported to a spreadsheet.
For example, the results in the Statistics window following a Fit can be exported.

It is recommended you work through all three parts of this tutorial to best understand how to
export tables.



Part 1. Exporting data from a table to a .CSV file.

Suppose one desires to provide a customized plot of an associated sample(s) and data.
Information to construct a plot can be created in a Table following a Solve or Fit and exported
to a .CSV file which can then be used for other purposes. The Tables window’s controls are
similar to the Plot window’s controls. They are found in the Set menu in Plot/Table Variables
and Plot/Table Scale. In Plot/Table Variables, you choose the variables you want to appear in
your table. In Plot/Table Scale, you set the scale (length of time or time interval) of your table.

1. Startthe SAAM Il Compartmental application. The SAAM Il Compartmental main

window will open.

2. Open the SAAM Il Compartmental study file study_0.

a. Inthe File menu, click Open. The file study_0.stu should appear in the file list; if it
does not, find the folder where you put this tutorial. Open the study file.

b. Inthe File menu, click Open. The SAAM Il Compartmental main window will
appear as shown below:

» % SAAM II Compartmental - STUDY _0.STU

File Edit View Show Compute Set Window Help

=101 x|

e EEREEEE

e EEET

Toolbox

I~ Lock
Experiment
Mame: tracer
Choose... | Rename...

Create... | Remove...

s | /

Select Sample

Change
Condition Input

[ Lock

o—JO

Madel I

- % STUDY_0.5TU:1

=101 x]

sl

E(2,1)
x(1,2)
{k{n,n
v

exl

-

AW

[ | 4

3. View the model and the experiment on the model. In the SAAM 11 Toolbox, click
Experiment. The model of the experiment will appear on the Drawing Canvas as

follows:




ki2,1)
kil 2

This is the experimental model developed and used in the Getting Started with
Compartmental tutorial.

4. Solve the model and view the solution.

a. Inthe Compute menu, click Solve, or alternatively, on the SAAM Il Toolbar, click

Solve ===,

b. In the Show menu, click Plot, or alternatively, on the SAAM Il Toolbar, click Plot

@. The Plot and Table Variables dialog box will open. Be sure the List All
Variables check box is not selected.

c. Click sl:plasma to move this to the Current Selection pane. The Plot and Tables
Variables dialog box will appear as follows:

Plot and Table Variables x|

Variables for Y-Axis X-Axis | t

Select up to 10 Y-Axis
Variables in List,

Current Selection :

51
plasma

[ List All Variables
Done I Cancel Help




d. Click Done. Your plot will appear as shown below (in linear mode):
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Leave the Plot window open.

I | eaving the Plot window open. During your modeling exercise, you can leave the
Plot window open and perform operations such as changing parameter values,
solving and fitting. As soon as you change a characteristic of your model such as
changing the value of the parameter, the solution will disappear from your plot. As
soon as you Solve or Fit, the updated solution will reappear.

L ¥

5. Fit the model to your data. In the Compute menu, click Fit, or alternatively, on the

SAAM 11 Toolbar click Fit M Since the Plot window was open during the “Fit”, the
Plot window will be updated as shown below:
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If you wish to see the plot in semilog mode, in the View menu, click Semilog. The
plot will change from linear to semilog as shown below:
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I |inear and semilog plots. To switch back and forth between linear and semilog plots,
in the View menu or right-click in the plot window, locate Semilog. If Semilog is
checked, the plot is semi-logarithmic. If Semilog is not checked, the plot is linear. To
switch back and forth, you need to go to the View menu, and select or cancel the



Semilog option. You may also access the Semilog selection by right-clicking your
mouse in the plot window.

3

Close the Plot window.
6. View the results in tabular form and save them to a .CSV file.

a. Inthe Show menu, click Table, or alternatively, on the SAAM Il Toolbar, click

Table . Since the Plot window was previously opened with a plot of s1 and
plasma, the Table window will open as follows:

[ Table =10 x|
| t gl plasma -
0000 44754 732 -
7.00000e-003 44808 .783 45780.000
4_20000e-002 43887777 43522000
0.125 42234 517 42535.000
0.250 33887.887 40125.000
0.375 37701.625 36221.000
0.500 35664 .642 25562000
0.750 31535.405 -
1.000 25802.803 28134.000
1.450 24050.218 -
1.725 Zleb4.652 -
Z.000 15801.133 15573.000
Z2.450 1&8738.027 -
2.725 15288.582 -
2.000 14121 .00% 14402.000
3.450 12337 _9&8 -
3.725 11506.245 -
4.000 10715. 885 1iz7e.000
4.450 9803457 -
4.725 S0ls6.183 -
5.000 2487 .332 8081 .000
5.450 778050 -
5.725 T315_.55¢& -
&_000 6344005 6335000
8.450 B8335.265 -
&.725 6093 _ 43¢ -
7.000 581z .411 5853000
7.450 5335.888 -
7.725 5182 .3¢8 -
g.000 45943185 5125_000
&.450 45811.751 -
g2.725 4424 .042 -
S.000 4246_276 - —
9.000 4245_276 4210.000 ;I




I Generating tables. The table contains the model calculated values at the times at
which there are data, and at times at which there are “calculation points”. The
“calculation points” are determined by the Minimum Number of Calculation
Intervals. This is a mechanism in SAAM Il by which the user can control the number
of values for samples that are saved for plotting and tabular purposes. Some plotting
packages may require more sample calculations. This can be achieved by increasing
the Minimum Number of Calculation Intervals as shown in the next part of this
Tutorial.

b. With the Table active (i.e. click the open Table), in the File menu, click Export

table (CVS)...,
File Edit WView Show Compute
Mew Cirl+M
Open... Ctrl+0
Close
Save Ctrl+5
Save As...

3l (C5Y)...

Print... Ctrl+P
Print One Copy Cirl+1
Print Preyiew
Print Setup...
Page Setup...
Exit Alt+F4

The Save As dialog box will open:



Cisavens x|
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LT, | | = 2011.10.28.Tables. Version 2.1 ~ TablesFies.Us.051030 - I‘Z_]J| Search TablesFiles,Us.051030 l!j_ﬂj

Organize =  Mew folder oo '9‘

't Favarites Documents library
B Desktop TablesFiles,US. 051030

& Downloads

=l Recent Places Mo items match your search.

Arrange by:  Folder

7 Libraries
3 Documents
J”r Music
&=/ Pictures
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File name: I |

=
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Save as type: ICS\I‘ Files (*.csv)

“ Hide Foldersl Save I Cancel |

&

Name your file “Study0 Best Fit”, and click Save. {You should keep track of where
the file is being saved.}

{You may also copy and paste Table Data directly into Excel or Word files: With
Table window active, hit Ctrl + C or select Copy in the Edit Menu; you may now
paste directly into another application.}

Close the table, but keep your SAAM Il model running.

7. Examine your .CSV file in Excel; it will look approximately:



EI= |=

| =

Home Insert Page Layout Formulas Data
& Cut Arial 10 v A AT =
53 Copy ~ .
- Format Painter B 7 O~ R-4A-|E
Clipboard Font
Al - Fe t
A B | C | D
1 t 57 plasma
2 0 44764 732 -
3 7.00E-03 44608.789 46780
4 4 20E-02 43887777 43522
5 0125 42234 517 42535
B 0.25 39887 687 40125
7 0375 37T01.625 36221
8 0.5 35664 642 35662
9 0.75 31995.409 -
10 1 28802.603 25194
11 1.45 24050.218
12 1.725 21664 652
13 2 19601.193 19573
14 245 16796.027
15 2725 15368982
16 3 14121.006 14403
17 3.45 12397968
18 3725 11506.245
19 4 10715.665 11278
20 445 9603.457
21 4725 9016.183
22 5 8487 392 5081
23 545 772805
24 5725 7318.556

Return to your SAAM |1 application and close all open Windows.



Part 2. Changing the resolution of the table.
1. Change the resolution of the table.

a. Inthe Compute menu, click Computational Settings. The Computational Settings
dialog box will open.

b. Change the Min. Nr. of Calculation Intervals from “20” to “200”. The
Computational Settings dialog box will appear as follows:

Min. Mr. of Calculations Intervals: « | (1 to 500)

~ Integrator
¥ Use Relative Error:
Pad | 0.00100000
Runge+futta (1.0e-10 to 1.0)
[ Use Absolute Error:
[T Compute Sample AUC's (greater than 0.0)
~ Optimizer

Max. Mr. of Fit Iterations: I 20 vI {0 to 50)

Variance Model ————— ~Derivative

{* Data i~ Absolute f* Forward
™ Model {* Relative " Central

Convergence Criterion: I 0,00010000

(1.0e-7 to 1.0)
[ Indude Bayesian Term

Lambda: I 10, 00000000 (1,0e-7 ko 1, 0e7)

[~ Save Results to Text File

Level————— File ————
r- Basic i RED'EIEE
" Detailed £ add

Al

Dane I Cancel | Help |

c. Click Done. The Table window will appear as follows:



& o

0=—0
n
b
¥
e.

_io/x
| t sl plasma
7.00000e-003 - 48780.000
4_20000e-002 - 43522 _000
0.125 - 42535.000
0.z50 - 40125.000
0.375 - 38221.000
0.500 - 35582.000
1.000 - 281594000
Z.000 - 15573.000
3.000 - 14403.000
4.000 - 11272.000
5.000 - B0B1.000
&.000 - 8335000
7.000 - 56532.000
2.000 - 5135._000
S.000 - 4210000

Changing a computational setting. When you change a computational setting in the
Computational Settings dialog box, this will change the characteristics of the
current solution. In this case, the Minimum Number of Calculation Intervals has
been increased. The reason why there are no values for sl is that the computational
settings have changed. The Table window can be updated with a Solve or a Fit.

Re-Solve :I the model. The Table window will appear (in part) as follows:
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[E Table =10 x|

| t gl plasma -

0.000 44754.732 -

7.00000e-003 44g08.785 45730.000

4_20000e-002 43887777 43522000

8_.35000e-002 43051.353 -
0.125 42234.517 42535.000
0.170 41370.364 -
0.z10 40620.557 -
0.250 358587.688 40125.000
0.235 33052.5814 -
0.335 38384 .404 -
0.375 27701.62% 26Z21.000
0.420 38551.721 -
0.480 26300.534 -
0.500 35664 .644 25562000
0.545 24585.715 -
0.530 34254 218 -
0.835 23615.685 -
0.&20 232571 . 664 -
0.725 22335.714 -
0.770 31723.404 -
0.gl1s 211zz_31%5 -
0.gs0 20536.051 -
0.5%05 2595964 _20% -
0.350 23408.333 -
0.375 25102 .434 -
1.000 28802 624 28154 000 ;I
1 ndAZ = e B =] -

Now there are many more values for s1 that have been saved in tabular form. This is
because of the increase in the minimum number of calculation intervals.

You can copy the contents of the table or export into a .CVS file as described
previously in Part 1.

1 Post plotting SAAM |1 output. Expanding the number of calculation intervals is very
useful if you want to post-process your output in a plotting package that requires
frequent calculated values.

3. Inthe Set menu, open the Computational Settings dialog box, and set the Min.Nr. of
Calculations Intervals to 1:



Computational Settings 7| x|
Min. Mr. of Calculations Intervals: I vI {1 to 500)

~ Integrator
¥ Use Relative Error:
- | 0.00100000
Runge+futta (1.0e-10 to 1.0)
[T Use Absolute Error:
[T Compute Sample AUC's (greater than 0.0)
 Optimizer
Max. Nr. of Fit Iterations: I 20 vI {0 to 50)
Variance Model ————— ~Derivative
{* Data i~ Absolute f* Forward
™ Model {* Relative " Central

Convergence Criterion: I 0.00010000

(1.0e-7 to 1.0}
[ Indude Bayesian Term

LLambda: I 10, 00000000 (1, 0e-7 ko 1,087

[~ Save Results to Text File

Level————— File ————
{ Basic | Replace
" Detailed £ add
Al

Dane I Cancel | Help |

4. Click Done. Solve :I the model. Your table will appear:
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[ TL I SR e o I I

=1 @y N

oo o

0.
7.00000e-
_Z0000e-

JR1=TE
I t =1 plasma |

Qoo 44754.732 -

ao3 44808.785 48780.000

a0z 432887.777 43522 .000

-125 47734.517 4Z535.000

-250 33887.887 40125.000

-375 37701.825 36221.000

-500 35664 . 6842 25582 .000

-000 28802 .581 Z8134.000

-000 13500.848 13573.000

-000 14115.248 14403.000

-000 10712.784 112728.000

-000 8485.080 8081.000

-000 8342 .350 &39%.000

-000 581z2.230 5853 .000

-000 4342 455 513%.000

-000 4745.812 - —

-000 4z45.81z2 4210.000 ;I

This table, which can be exported, has just the model solutions and data. In a .CVS file it
can be copied into other documents such as Word.

5. Create a table of weighted residuals

a.  With the minimum number of calculation intervals set equal to 1, tabular output can
be quite useful for, for example, statistical testing. With your table open, in the Set
menu, Click Plot/ Table Variables, or alternatively click the Select variables tool
on the SAAM 11 Toolbar. Be sure the List All Variables check box is checked.
Click on s1_wres; the Plot and Tables Variables dialog box will appear:

Plot and Table Variables x|

Variables for Y-Axis

ex 1.bolus
ex Linfusion
flux(o, 1)
flux(1,2)
flux(2,1)
k{0, 1)
k(1,2)
k(2,1)
plasma

W List All Variables

Done I Cancel Help

X-Axis I t

Select up to 10 ¥-Axis
Variables in List.

Current Selection :
s51_wres




b. Click Done.

c. Fit III_-] your model to your data. Your table will be updated:

_ioix]
| t 3l _wres =
0.000 -
7.00000e-003 1.351
4 _20000e-002 -2 _.51800e-001
0.125 0.21z
0.250 0.177
0.375 -1.22471e+000
0.500 -8.64747e-002
1.000 -€.46711e-001
Z2.000 -4 _Z&Z78e—-002
3.000 0.532
4_000 1.502
5.000 -1.4928314e+000
&.000 0.243
7.000 -8.44Z224e-001
2.000 1.148
5.000 - —
53.000 -Z.54858e—-001 ;I

The weighted residuals can now be exported to a .CSV file, and can be used, for
example, in a runs test for goodness-of-fit.

d. Close your table; leave your model running.



Part 3. Exporting Statistical Information
1. View the statistical information

2. Be sure you have fitted your model to your data. Open the Statistics window:

bl Statistics ) [m] 4|
Parameter/Variakle Value Std_Dev. ©Coef. of Var. 95% Confidence Interval
k(d,1) 0.29227 1_.46251e-00Z 5.00338e+000 0.Ze008 D-SE-I-IE;I
ki{l,2) 0.28311 7.51¢40e-002 Z2.854%8e+001 0.117&7 0.44354
kiz, 1) 0.17452 1.82550e-002 1.04803e+001 0.13434 0.21470
wvol 2323 _7768l 3_B5¢cccet001 1.&558685e+000 2238.8913% 2408 .8812¢
el
" Correlation Matrix " Covariance Matrix {* Objective
Objective Scaled Data Variance -
31 : plasma 1.33€791e+001 1.114045e-001
Total cbkjectiwve 1.3368791e+001
ATIC 7.93€225e4+000
BIC 8.054233e+000 _ILI
Kl E

3. On the File menu, click Export statistics (CSV)...

File Edit View Show Compute Set

Mew Cirl+M
Open... Cirl+0
Close

Save Ctrl+5
Save As...

Expart statistics (C5V)...

F'rir'lt.l:":i Ctrl+P
Print One Copy Cirl+1
Primk Presvies

Print Setup...

Fage Setup...

Exit Alt+F4

The Save As dialog box will open. You can save the file as a .CSV file; with the column
width adjusted, in Excel it will look like:



@l LH Lo |= Statistics.csv - Microsoft Bx

Home Insert Page Layout Formulas Data Review View

& Cut Arial oAy = E[;] P = Wrap Text General
) =3 Copy - R P S
Faste - - = == £ *= | | ] - - 0
o Format Painter B 7 -y E = = | tE £E [ Merge & Center % Y
Clipboard - Faont ) Alignment ) MNumb
D1a - I
A B C ] E F G
1 Parameter\ariab Value Std.Dev. Coef. of Var. 95% Confidence Interval
2 k(0,1) 0.29227 1.46E-02 5. 00E+00 0.26008 0.32446
3 k(1.2) 028311 7 62E-02 2 BAE+01 011767 044854
4 ki2,1) 017452 1.83E-02 1.05E+01 013434 02147
5 ol 2323.77661 3.86E+01 1.66E+00 2238.89196 2408 66126
6 Objective Scaled Data Variance
7 s1:plasma 1.34E+01 1.11E-01
8| 00|
9 Total objective 1.34E+01
10
11 AIC T.94E+00
12 BIC 8.05E+00

The Excel file can then be used in other applications if you wish.

4. Close all open windows in SAAM II.

Quit the SAAM |1 Compartmental application.
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