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Using SAAM II Working with Plots 

Working with Plots 
 

Prerequisites 
 

The prerequisite for this tutorial is having worked through the SAAM II introductory 

tutorial, “Getting Started with SAAM II Compartmental.” 

 

What you will learn in this tutorial 

 

The purpose of this tutorial is to show you how to view the results of your modeling exercise 

using plots. You will learn 

 

 How to view line plots of your data (Part 1) 

 How to change plot variables (Part 2) 

 How to change the viewing areas of the X- and Y-axis (Part 3) 

 How to create labels on your plots (Part 4) 

 How to increase the resolution of your plots (Part 5) 

 How to change the variable on the X-axis (Part 6) 

 

Files Required 

 

Study Files: The study file for this tutorial is 

 

study_0.stu 

 

This file is included as part of this tutorial. This file is the same as study_0.stu that is 

installed in the SAAM II program folder and referred to in the SAAM II examples. 

 

Remember study_0 is a study file for an experiment lasting 9 days. 

 

Introduction 

 

This tutorial focuses on the features involved in viewing and refining plot output from SAAM 

II. The first part will show you have to create line plots of your data, and how creating such 

plots can help you in the early stages of model development and testing. 

 

The next three parts of the tutorial will discuss the options in the Set menu when a Plot window 

is current. In these parts, the independent variable will always be “t” for time. In Part 6 you will 

learn how to change the variable on the X-axis. 

 

In Part 5 you will learn how to increase the resolution of your plot. This is very useful when 

your model solution is changing quickly. It is also useful if you wish to export the information 

about your plot to another plotting package. 
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This tutorial will not discuss the Quick Plot feature. Quick Plot permits visualizing plots rapidly 

but, except for switching between linear and semilog, you cannot change the format of the plot. 

Remember you can obtain a quick plot of any object in your model on the Drawing Canvas by 

clicking on that object, and then in the View menu, click Quick Plot. 

 

SAAM II is not intended to be a graphics software tool. The intent of the plotting options in 

SAAM II is to help you in your modeling exercises. For presentation graphics, you can save the 

results from SAAM II in, for example, a table and use this in your favorite graphics package. 

 



Part 1. Working with line plots 
 

Line plots are a convenient way by which you can learn about characteristics in your data before 

you start your modeling exercise. Line plots can help you decide how many compartments you 

may need in your model, and can be used to help obtain initial parameter estimates for your 

model. Line plots in SAAM II are created by linear extrapolation between sequential pairs of 

data. 

 

1. Start the SAAM II Compartmental application. The SAAM II Compartmental main 

window will open. 

 

2. Open the SAAM II Compartmental study file study_0. 

 

a. The file study_0.stu should appear in the file list; if it does not, find the folder where 

you put this tutorial. 

 

b. In the File menu, click Open. The SAAM II Compartmental main window will 

appear as shown below: 

 

 

 
 

3. View the model and the experiment on the model. In the SAAM II Toolbox, click 

Experiment. The model of the experiment will appear on the Drawing Canvas as 

follows: 
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This is the experimental model developed and used in the Getting Started with 

Compartmental tutorial.  

 

4. Create a line plot of the data. 

 

a. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, click Plot 

. The Plot and Table Variables dialog box will open. The List All Variables 

check box is not selected so s1:plasma is the only option in the Variables for Y 

Axis pane. 

 

b. In the Plot and Table Variables dialog box, select the List All Variables check 

box. All variables that can be plotted will appear in the Variables for Y Axis pane. 

 

c. Click plasma to add this to the Current Selection pane. The Plot and Table 

Variables dialog box will appear as shown below: 

 
d. Click Done. A plot of the “plasma” data will appear in the Plot window. 
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e. In the View menu, click Line Plot. The line plot will appear in linear mode as 

follows: 

 

 
 

f. If you wish, you can view the line plot in semi-log mode. In the View menu, click 

Semilog. The line plot will change to a semi-log plot as shown below: 
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 Using line plots. You can see immediately from this line plot that the data do not 

decay monoexponentially, so the model used to describe them cannot be a one-

compartment model. When you are starting a modeling exercise from scratch, it is 

always a good idea to look at your data using the line plot feature in SAAM II. 

 
 

 

 Linear and semilog plots. To switch back and forth between linear and semilog plots, 

in the View menu, locate Semilog. If Semilog is checked, the plot is 

semilogarithmic. If Semilog is not checked, the plot is linear. To switch back and 

forth, you need to go to the View menu, and select or cancel the Semilog option. 

 
 

5. Close the Plot window. 

 

Quit the SAAM II Compartmental application. Do not save the changes to study_0. 
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Part 2. Using the “Plot/Table Variables” command in the “Set” menu. 

 

There are three options available in the Set menu when a Plot window is open. One allows you 

to choose the variables to be plotted on the Y- and X-axes. The second allows you to change the 

scale on the Y- and X-axis. The last allows you to label your plots. This part of the tutorial will 

show you have to use the Plot/Table Variables command in the Set menu to change the 

variable on the Y-axis only. Changing the variable on the X-axis is discussed in Part 6. 

 

A new feature introduced in SAAM II version 2.1 permits you to access these options with new 

tools on the SAAM II Toolbar. The old Toolbar is shown below: 

 

 
 

The enhanced Toolbar is: 

 

 
 

After the Fit tool, there are three new tools that are dimmed. When a Plot is open, the Toolbar 

will appear: 

 

 
 

The three new tools permit you to rapidly open the PLOT AND TABLE VARIABLES, PLOT 

AND TABLE SCALE, and PLOT LABEL dialog boxes. 

 

 Accessing the options for plots. A second quick method by which you can open the 

SET menu when a PLOT is active is to right click on the plot. If you right click 

inside the plot window, the following menu selection will open, and you can proceed 

to change Variables, Scale or Labels; you may also use this menu to change the plot 

to/from Semilog, to/from Linear, turn on the Grid or Line Plot and Copy or Export 

the plot. 
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 Plot and Table Variables. The purpose of the Plot/Table Variables command is to 

allow you to plot any variable in your model against an independent variable.  The 

default independent variable is “t.” An example of the Plot and Table Variables 

dialog box is shown below. 

 

 
 

The dialog box consists of three panes and one check box. The three panes are the 

Variables for Y-Axis, X-Axis and Current Selection. The check box is List All 

Variables. 
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The Variables for Y-Axis pane contains all variables which can be plotted against 

the variable on the X-axis. When the List All Variables check box is not selected, as 

is the case above, only those variables associated with samples will be available. 

When the List All Variables check box is selected, an example of which is shown 

below, all variables that can be plotted are listed. 

 

 
 

The Current Selection pane shows those variables that you have selected to plot. 

 

In the X-Axis box, you can change the name of the independent variable from “t” to 

another variable in the model. 

 
 

1. Start the SAAM II Compartmental application. The SAAM II Compartmental main 

window will open. 

 

2. Open the SAAM II Compartmental study file study_0. 

 

a. The file study_0.stu should appear in the file list; if it does not, find the folder where 

you put this file. 

 

b. In the File menu, click Open. The SAAM II Compartmental main window will 

appear as shown below: 
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3. View the model and the experiment on the model. In the SAAM II Toolbox, click 

Experiment. The model of the experiment will appear on the Drawing Canvas as 

follows: 

 

 
 

This is the experimental model developed and used in the Getting Started with 

Compartmental tutorial. 

 

4. Solve the model and view the solution. 

 

a. In the Compute menu, click Solve, or alternatively, on the SAAM II Toolbar, click 

Solve . 



Using SAAM II Working with Plots 

b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, click Plot 

. The Plot and Table Variables dialog box will open. Be sure the List All 

Variables check box is not selected. 

 

c. Click s1:plasma to move this to the Current Selection pane. The Plot and Tables 

Variables dialog box will appear as follows: 

 

 
 

d. Click Done. Your plot will appear as shown below (in linear mode): 
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Leave the Plot window open. 

 

 Leaving the Plot window open. During your modeling exercise, you can leave the 

Plot window open and perform operations such as changing parameter values, 

solving and fitting. As soon as you change a characteristic of your model such as 

changing the value of the parameter, the solution will disappear from your plot. 

When you Solve or Fit, the updated solution will reappear. 

 
 

5. Fit the model to your data. In the Compute menu, click Fit, or alternatively, on the 

SAAM II Toolbar click Fit . Since the Plot window was open during the “Fit”, the 

Plot window will be updated as shown below: 

 

 
 

If you wish to see the plot in semilog mode, in the View menu, click Semilog. The 

plot will change from linear to semilog as shown below: 
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 Linear and semilog plots. To switch back and forth between linear and semilog plots, 

in the View menu, locate Semilog. If Semilog is checked, the plot is 

semilogarithmic. If Semilog is not checked, the plot is linear. To switch back and 

forth, you need to go to the View menu, and select or cancel the Semilog option. 

 
 

 Leave the Plot window open. If you do not leave the Plot window open, when you open 

the Set menu, the options in the Set menu for plots will not be available. 

 

5. Plot q1 and q2, the solution to the differential equations represented by your 

compartmental model, versus time.  

 

a. In the Set menu, click Plot/Table Variables. The PLOT AND TABLE 

VARIABLES dialog box will open. 

 

Alternatively, click the Select variables tool in the SAAM II Toolbar: 

 

 
 

The PLOT AND TABLE VARIABLES dialog box will open. 
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 Opening the PLOT AND TABLE VARIABLES dialog box. There are now three 

ways to open this dialog box. One is from the Set menu, one is using the Select 

variables tool in the SAAM II Toolbar and the third way is right-clicking in a plot 

window. 

 
 

In the Plot and Table Variables dialog box, be sure the List All Variables check 

box is selected. Notice s1 and plasma are selected since this was your last plot. 

 

b. Click q1, and then press the CTRL key, and click q2. The variables q1 and q2 will 

move to the Current Selection pane as shown below: 

 

 
 

If you had pressed the CTRL key and clicked q1 and q2, because s1 and plasma 

were already selected, q1 and q2 would have been added to the Current Selection 

pane. Clicking q1 first removes s1 and plasma from the Current Selection pane. 

 

c. Click Done. The plot of q1 and q1 in linear mode will appear as follows (if the plot 

is not in the linear mode, in the View menu, click Semilog): 
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d. In the View menu, click Semilog. The plot will change to semilog as follows: 

 

 
 

e. Close the Plot window. 

 

7. Plot the weighted residuals from your “Fit.”  

 

 Residuals and weighted residuals. For each datum, the residual is the difference 

between the model calculated value and the datum. For this example, it appears as 
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s1_res. The weighted residual is the residual times the weight assigned to the datum. 

It appears as s1_wres. The residuals or weighted residuals should be randomly 

distributed above and below zero. Systematic deviations may indicate that your 

model is not satisfactory. Analyzing the residuals is an important part of a posteriori 

model identifiability. 

 
 

a. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, click Plot 

. Your plot of q1 and q2 will appear in the Plot window. 

 

 SAAM II remembers plots. Once you create a plot, SAAM II will remember the plot 

variable(s) the next time you open the Plot window. Thus if you want to change the 

variable(s) in the Plot window, you must have a Plot window current and use the 

Plot/Table Variables option in the Set menu. 

 
 

b. In the Set menu, click Plot/Table Variables, or alternatively click the Select 

variable tool in the SAAM II Toolbox. Be sure the List All Variables check box is 

selected in the Plot and Table Variables dialog box.  

 

c. Click s1_wres (these are the weighted residuals from your “Fit”) to move this 

variable to the Current Selection pane as shown below: 
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d. Click Done. The plot of the weighted residuals will appear as follows: 

 

 
It is clear that the plot of the weighted residuals is very strange. The reason is that the 

plot is in the semilog mode. It is necessary to view the weighted residuals (or 

residuals) in the linear mode. 

 

e. In the View menu, click Semilog (this will return the plot to a linear plot). The plot 

of the weighted residuals in linear mode will appear as follows: 

 
 

 f. Close the Plot window. 

 

You have now explored some of the options to change the variables for the Y-axis.  

Quit the SAAM II Compartmental application. Do not save the changes to study_0. 
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Part 3. Using the “Plot/Table Scale” command in the “Set” menu. 

 

There are three options available in the Set menu when a Plot window is open. One allows you 

to choose the variables to be plotted on the Y- and X-axes. The second allows you to change the 

scale on the Y- and X-axis. The last allows you to label your plots. This part of the tutorial will 

show you have to use the Plot/Table Scale command in the Set menu 

 

 

There are three options available in the Set menu when a Plot window is open. One allows you 

to choose the variables to be plotted on the Y- and X-axes. The second allows you to change the 

scale on the Y- and X-axis. The last allows you to label your plots. This part of the tutorial will 

show you how to change the variable on the Y-axis only. Changing the variable on the X-axis is 

discussed in Part 6. 

 

A new feature introduced in SAAM II version 2.1 permits you to access these options with new 

tools on the SAAM II Toolbar. The old Toolbar is shown below: 

 

 
 

The enhanced Toolbar is: 

 

 
 

After the Fit tool, there are three new tools that are dimmed. When a Plot is open, the Toolbar 

will appear: 

 

 
 

The three new tools permit you to rapidly open the PLOT AND TABLE VARIABLES, PLOT 

AND TABLE SCALE, and PLOT LABEL dialog boxes. 

 

 Plot and Table Scale. The purpose of the Plot/Table Scale command is to allow you 

to change the scale of the Y- or X-axis so you can visualize areas of your plot in 

more detail. An example of the Plot and Table Scale dialog box is shown below: 
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The dialog box consists of two panes, the X Axis and Y Axis pane. Within both 

panes are the AutoScale and Set options. The default for both is AutoScale; SAAM 

II will determine for a particular plot what the most appropriate values for the 

Minimum and Maximum are. 

 

If you select the Set option, then you can enter your own values for the Minimum or 

Maximum 

 
 

1. Start the SAAM II Compartmental application. The SAAM II Compartmental main 

window will open. 

 

2. Open the SAAM II Compartmental study file study_0. 

 

a. The file study_0.stu should appear in the file list; if it does not, find the folder where 

you put this file. 

 

b. In the File menu, click Open. The SAAM II Compartmental main window will 

appear as shown below: 
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3. View the model and the experiment on the model. In the SAAM II Toolbox, click 

Experiment. The model of the experiment will appear on the Drawing Canvas as 

follows: 

 

 
 

This is the experimental model developed and used in the Getting Started with 

Compartmental tutorial. 

 

 

4. Solve the model and view the solution. 

 

a. In the Compute menu, click Solve, or alternatively, on the SAAM II Toolbar, click 

Solve . 

 

b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, click Plot 

. The Plot and Table Variables dialog box will open. Be sure the List All 

Variables check box is not selected. 
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c. Click s1:plasma to move this to the Current Selection pane. Your plot will appear 

as shown below (in linear mode): 

 

 
 

Leave the Plot window open. 

 

5. View details of the solution between time zero and 1.5 days. 

 

It is clear that the model predicted value at time zero is higher than the initial data would 

suggest. This means that vol is not large enough. However, without having a better view 

of the initial decay, it is difficult to tell how to change vol.  

 

a. In the Set menu, click Plot/Table Scale. Alternatively, click the Set scales tool in 

the SAAM II Toolbar: 

 

 
The Plot and Table Scale dialog box will open as follows: 
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 Autoscaling. SAAM II will automatically set the scales for the X-axis and Y-axis 

based upon the data/solution and the time of the experiment. The default is the 

AutoScale option. 

 
 

b. In the X Axis pane, choose Set. Type “-0.05” in the Minimum box, and “1.5” in the 

Maximum box. Setting the minimum equal to -0.05 will allow you to visualize the 

time zero situation better. 

 

c. In the Y Axis pane, choose Set. Type “30000” in the Minimum box, and “60000” in 

the Maximum box. The Plot and Table Scale dialog box should appear as shown 

below: 

 

 
 

d. Click Done. The plot of the initial decay will appear as follows: 
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e. Change the estimate for vol. 

 

You can see from the detailed plot that the model predicted concentration value at 

time zero is about 52,000 while the data would suggest a value closer to 48,000. If 

you open the Parameters dialog box, you will see the initial estimate for vol is 2000. 

The estimate of 52,000 comes from the dose, 1.04e+08, divided by the estimated 

value of 2000 for vol. To get closer to the desired 48,000, vol must equal 

1.04e+08/48000, or approximately 2167. 

 

In the Parameters dialog box, change the Value for vol to 2167. Re-Solve the 

model. The plot of the initial decay will update as follows: 
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f. Close the Plot window. 

 

6. Fit the model to the data and view the results. 

 

a. In the Compute menu, click Fit, or alternatively, on the SAAM II Toolbar click Fit 

. 

 

b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, click Plot 

. The plot of the initial decay will appear as follows: 

 

 
 

 SAAM II remembers plots and scales. Once you create a plot and set the scale of the 

plot, SAAM II will remember the plot variable(s) and scale the next time you open 

the Plot window. Thus if you want to change the variable(s) and/or scale in the Plot 

window, you must use the Plot/Table Variables and/or Plot/Table Scale options in 

the Set menu, or the respective tools in the SAAM II Toolbar. 

 
 

c. In the Set menu, click Plot/Table Scale, or click the Set scales tool in the SAAM II 

Toolbar. The Plot and Table Scale dialog box will open. 

 

d. In both the X Axis and Y Axis panes, select Autoscale. The Plot and Table Scale 

dialog box will appear as follows: 
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e. Click Done. The plot will appear (in semilog mode) as follows: 

 

 
 

f. View the final decay in more detail. 

 

(1) In the Set menu, click Plot/Table Scale, or click the Set scales tool in the 

SAAM II Toolbar, or right-click in the plot window and select Scale… The Plot 

and Table Scale dialog box will open. 

 

(2) Set the Minimum and Maximum in the X Axis pane equal to “4.9” and “9.5” 

respectively. Set the Minimum and Maximum in the Y Axis pane equal to 

“4000” and “10000” respectively. The Plot and Table Scale dialog box will 

appear as follows: 
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(3) Click Done. The plot of the final decay will appear as follows: 

 

 
 

You can see that the model fit of the final decay is quite reasonable, and that the 

residuals or weighted residuals should be randomly distributed around zero. 

 

(4) Close the Plot window. 

 

7. View the weighted residuals. 

 

a. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, click Plot 

. Your previous plot will open. 

 

b. In the Set menu, click Plot/Table Variables, or click the Select variables tool in the 

SAAM II Toolbar. Be sure the List All Variables check box is selected. Notice that 

plasma and s1 are in the Current Selection pane. 
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c. Click s1_wres to move this to the Current Selection pane.  

 

d. Click Done. The plot of the weighted residuals will appear as follows 

 

 

 SAAM II remembers scales. Once you create a plot and set the scale, SAAM II will 

remember the scale the next time you open the Plot window. Thus if you want to 

change the scale in the Plot window, you must use the Plot/Table Scales option in 

the Set menu, or the Set scales tool in the SAAM II Toolbar. 

 
e. In the Set menu, click Plot/Table Scale, or click the Set scales tool in the SAAM II 

Toolbar. The Plot and Table Scale dialog box will open. 

 

f. In the X Axis pane, click Autoscale. In the Y Axis pane, set the Minimum and 

Maximum values equal to “-2” and “2” respectively. The Plot and Table Scale 

dialog box will appear as follows: 
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g. Click Done. The plot of the weighted residuals will appear as follows: 

 

   
 

The problem now is that the plot is semilog, and to visualize the weighted residuals, 

the plot must be linear. 

 

h. In the View menu or right-click in the plot window, click Semilog. The plot of the 

weighted residuals will appear as follows: 

 

 
 

You can see the weighted residuals are randomly distributed about zero. It is difficult 

to visualize the initial residuals. You can set the time scale from “0” to “1.5” or “2.0” 

if you wish to see the initial residuals better. An example is shown below: 

 



Using SAAM II Working with Plots 

 
 

i. Close the Plot window. 

 

Quit the SAAM II Compartmental application. Do not save the changes to study_0. 
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Part 4. Using the “Plot/Table Label” command in the “Set” menu. 

 

It is sometimes useful to label plots. In what follows, labels will be put on the plot of s1 and 

plasma. 

 

 Plot and Table Labels. The  Plot/Table Labels command or Edit plot labels tool 

allows you to put labels on your plots, and to change the font size of the label if you 

wish. An example of the Plot Labels dialog box is shown below: 

 

 
 

There are three boxes in which you can enter information, and the ability to change 

the font size. The Title will appear across the top of your plot. The entries in the X 

Axis and Y Axis boxes will appear respectively along the X- and Y-axes. 

 
 

1. Start the SAAM II Compartmental application. The SAAM II Compartmental main 

window will open. 

 

2. Open the SAAM II Compartmental study file study_0. 

 

a. The file study_0.stu should appear in the file list; if it does not, find the folder where 

you put this tutorial. 

 

b. In the File menu, click Open. The SAAM II Compartmental main window will 

appear as shown below: 
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3. View the model and the experiment on the model. In the SAAM II Toolbox, click 

Experiment. The model of the experiment will appear on the Drawing Canvas as 

follows: 

 
 

This is the experimental model developed and used in the Getting Started with 

Compartmental tutorial. 

 

4. Solve the model and view the solution. 

 

a. In the Compute menu, click Solve, or alternatively, on the SAAM II Toolbar, click 

Solve . 
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b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, click Plot 

. The Plot and Table Variables dialog box will open. Be sure the List All 

Variables check box is not selected. 

 

c. Click s1:plasma to move this to the Current Selection pane. Your plot will appear 

as shown below (in linear mode): 

 

 
 

Leave the Plot window open. 

 

4. Fit the model to the data and view the results. 

 

a. In the Compute menu, click Fit, or alternatively, on the SAAM II Toolbar click Fit 

. The plot will be updated as follows: 
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6. Label the plot. 

 

a. In the Set menu, click Plot Labels. Alternatively, click the Edit plot labels tool in 

the SAAM II Toolbox, or right-click in the plot window and select Labels. 

 

 
 

 The Plot Labels dialog box will open a shown below: 

 

 
 

b. Enter the following: 

 

(1) In the Title box, type “Plasma Decay”. 

 

(2) In the X Axis box, replace “t(days)” with “Days” 
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(3) In the Y Axis box, type “Concentration (dpm/ml)”. The Plot Labels dialog box 

will appear as follows: 

 

 
 

(4) Click Done. Your plot will appear as follows: 

 

 
 

c. Close the Plot window. 

 

Quit the SAAM II Compartmental application. Do not save the changes to study_0. 

 



Using SAAM II Working with Plots 

Part 5. Increasing the plot resolution. 

 

It is sometimes useful to increase the resolution of the plots produced by SAAM II. This is done 

by increasing the number of Calculations Intervals. As explained below, the Calculations 

Intervals are used to determine at which time points SAAM II saves solutions for the purpose of 

creating plots and tables. 

 

 Calculation Intervals. For each model experiment, there are a number of calculation 

points (times) when SAAM II stores the solution to your model for plotting and 

tabular purposes. The number of calculation points (times) is determined by the 

number of independent variable data points in the data file and the value of the 

Minimum Number of Calculations Intervals. The default value for the minimum 

number of calculation intervals is 20; this value can range from 1 to 500.  

  

There may be times when you wish to increase, or decrease, the resolution of your 

plot. This happens most frequently when your solution is changing rapidly with, for 

example, rapid rises and falls in the data. The default value for the minimum number 

of calculations intervals may not be large enough to permit viewing these details. To 

view these details effectively, you must increase the minimum number of 

calculations intervals. 

 

To set this number, in the Compute menu, click Settings. Enter the desired number 

in the Min. Nr. of Calculations Intervals box at the top of the Computational 

Settings dialog box. Increasing the number of Calculation Intervals results in longer 

computation times. This won’t be noticeable unless you have a complex problem 

requiring several seconds or minutes to solve. 

 
 

 

1. Start the SAAM II Compartmental application. The SAAM II Compartmental main 

window will open. 

 

2. Open the SAAM II Compartmental study file study_0. 

 

a. The file study_0.stu should appear in the file list; if it does not, find the folder where 

you put this file. 

 

b. In the File menu, click Open. The SAAM II Compartmental main window will 

appear as shown below: 
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3. View the model and the experiment on the model. In the SAAM II Toolbox, click 

Experiment. The model of the experiment will appear on the Drawing Canvas as 

follows: 

 
This is the experimental model developed and used in the Getting Started with 

Compartmental tutorial. 

 

4. Solve the model and view the solution. 

 

a. In the Compute menu, click Solve, or alternatively, on the SAAM II Toolbar, click 

Solve . 

 

b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, click Plot 

. The Plot and Table Variables dialog box will open. Be sure the List All 

Variables check box is not selected. 
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c. Click s1:plasma to move this to the Current Selection pane. Your plot will appear 

as shown below (in linear mode): 

 

 
 

Leave the Plot window open. 

 

5. Fit the model to the data and view the results. 

 

a. In the Compute menu, click Fit, or alternatively, on the SAAM II Toolbar click Fit 

. The plot will be updated as follows: 

 

 
 

6. Increase the resolution of the plot. 



Using SAAM II Working with Plots 

a. In the Compute menu, click Settings. The Computational Settings dialog box will 

open as shown below (notice the Plot window is also open but is not available as the 

Computational Settings dialog box is current.) 

 

 
 

b. In the Min. Nr. of Calculations Intervals box, type 200, or select 200 in the Min. 

Nr. of Calculations Intervals box. The Computational Settings dialog box will 

appear as follows: 
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c. Click Done. The Computational Settings dialog box will close. Your plot remains, 

but the solution disappears. This is because the current solution settings do not match 

the ones used to create the previous plot. 

 

7. Solve your model. The new solution with 200 calculation intervals appears in the Plot 

window. It is not substantially different from the previous plot. 

 

 

 When to increase plot resolution. SAAM II uses the Calculation Intervals to 

determine when to save solutions for plotting and tabular purposes. Plots are created 

by linearly interpolating between saved pairs of calculation points. When your 

solution is rising and falling rapidly as in the case of oral absorption or in calculating 

24 hour urine collections, peak values may be missed if the Minimum Number of 

Calculation Intervals is not large enough. You can often see this in your model 

solution. When this happens, simply increase the number of intervals. 
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Consider the following example of a drug which was infused into plasma over a five 

minute interval. The plot shown as follows is with the default value of 20 for the 

Minimum Number of Calculation Intervals. 

 

 
 

If the minimum is set to 200, the plot will change as follows: 

 

 
 

Now you can see the rising portion of the solution. 
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The default value of 20 for the Minimum Number of Calculation Intervals was 

determined to be the most efficient in most cases where efficiency relates both to 

numerical calculation time and the quality of the plot. As with most default settings, 

it is not perfect and on occasion must be adjusted. 

 
 

A solution of an infusion using Minimum Number of Calculation Intervals = 20 

 
 

And the solution of the infusion using Minimum Number of Calculation Intervals = 200 

 
 

Quit the SAAM II Compartmental application. Do not save the changes to study_0. 
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Part 6. Changing the variable on the X-axis. 

 

It is sometimes important to be able to change the variable on the X-axis. In what follows, the 

variables q2 and q2/q1 will be plotted as a function of the variable q1.  

 

 Plot and Table Variables. The Plot/Table Variables command allows you to plot 

any variable in your model against the independent variable “t.” In addition, and as 

will be explained below, in the X-axis box, you can change the name of the 

independent variable from “t” to another variable in the model. While this situation 

does not arise often in multicompartmental modeling, it does arise when using the 

SAAM II Numerical application’s Michaelis-Menten and Scatchard equations. Here 

one wants to recreate, for example, the Lineweaver-Burke plot. This involves 

changing the variable for the X-axis. 

 
 

1. Start the SAAM II Compartmental application. The SAAM II Compartmental main 

window will open. 

 

2. Open the SAAM II Compartmental study file study_0. 

 

a. The file study_0.stu should appear in the file list; if it does not, find the folder where 

you put this file. 

 

b. In the File menu, click Open. The SAAM II Compartmental main window will 

appear as shown below: 
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3. View the model and the experiment on the model. In the SAAM II Toolbox, click 

Experiment. The model of the experiment will appear on the Drawing Canvas as 

follows: 

 
This is the experimental model developed and used in the Getting Started with 

Compartmental tutorial. 

 

4. Solve the model and view the solution. 

 

a. In the Compute menu, click Solve, or alternatively, on the SAAM II Toolbar, click 

Solve . 

 

b. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, click Plot 

. The Plot and Table Variables dialog box will open. Be sure the List All 

Variables check box is not selected. 

 

c. Click s1:plasma to move this to the Current Selection pane. Your plot will appear 

as shown below (in semilog mode): 
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Leave the Plot window open. 

 

5. Fit the model to the data and view the results. 

 

a. In the Compute menu, click Fit, or alternatively, on the SAAM II Toolbar click Fit 

. The plot will be updated as follows: 

 

 
 

Leave the Plot window open. 

 

6. Plot q2 versus q1. 

 

a. In the Set menu, click Plot/Table Variables, or alternatively click the Select 

variables tool in the SAAM II Toolbox or right-click in the plot window. The Plot 

and Table Variables dialog box will open. 

 

b. Select the List All Variables check box. 

 

c. Click q2 to move it to the Current Selection pane. 

 

d. Type “q1” in the X Axis box. The Plot and Table Variables dialog box will appear 

as follows: 
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e. Click Done. The plot of q2 versus q1 will appear in linear mode as follows: 

 

 
 

f. Close the Plot window. 

 

7. Plot q2/q1 versus q1. 

 

a. In the SAAM II Toolbox, click Sample. 
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b. Click Compartment q1 and then click the Drawing Canvas. The sample s2 will 

appear associated with Compartment q1. 

 

c. Double-click s2 to open the Samples Attributes dialog box. Edit the sample 

equation to read “s2 = q2/q1”. The Sample Attributes dialog box will appear as 

follows: 

 
 

d. Click Done. Your model will appear as shown below: 

 

 
 

Notice s2 is connected to both Compartments q1 and q2; this is because both q1 and 

q2 appear in the sample equation s2. Notice also s2 is open since it is not associated 

with data. 

 

e. Re-Solve or Re-Fit the model. Since you have previously “Fitted” the model to the 

data, both will produce the same result. 

 

f. In the Show menu, click Plot, or alternatively, on the SAAM II Toolbar, click Plot 

. The Plot and Table Variables dialog box will open. Be sure the List All 

Variables check box is selected. 

 



Using SAAM II Working with Plots 

 Remembering plots. In general, when you create a plot, the Plot window will open 

with the previous plot. In this way, SAAM II remembers plots. This is not the case in 

this situation because the previous plot did not have the variable “t” in the X Axis 

box. Because of this, when you open the plot, the Plot and Table Variables dialog 

box opened. 

 
 

g. Click s2 to move this variable to the Current Selection pane. Remember s2 is your 

quotient q2/q1. 

 

h. Type “q1” in the X Axis box. The Plot and Table Variables dialog box will appear 

as follows: 

 

 
 

i. Click Done. The plot of q2/q1 versus q1 will appear in linear mode as follows: 
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j. Close the Plot window. 

 

Quit the SAAM II Compartmental application. Do not save the changes to study_0. 
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